Forums des Landes Eternelles
https://landes-eternelles.com/phpBB/

[Linux] erreur au lancement
https://landes-eternelles.com/phpBB/viewtopic.php?f=104&t=29450
Page 2 sur 2

Auteur:  trinita [ 10 Déc 2015, 21:46 ]
Sujet du message:  Re: [Linux] erreur au lancement

perso je pense à un soucis avec la version de cal3D

Auteur:  Zuthos [ 11 Déc 2015, 07:31 ]
Sujet du message:  Re: [Linux] erreur au lancement

trinita a écrit:
peux tu donner la version de cal3D ?


La version de libcal3d12.dev est 0.11.0-6

Auteur:  Sebastien [ 11 Déc 2015, 15:25 ]
Sujet du message:  Re: [Linux] erreur au lancement

Pour ma part depuis la logithèque ubuntu, j'ai 2 paquets de cal3d d'installés :

libcal3d12 (version : libcal3d12 0.11.0-4.1)

et

libcal3d12-dev (version : libcal3d12-dev 0.11.0-4.1).

Auteur:  Ektorek [ 27 Déc 2015, 16:19 ]
Sujet du message:  Re: [Linux] erreur au lancement

Bonjour à tous, et bonnes fêtes.
Ayant un peu de temps libre, j'ai eu envie de rejouer un peu à LE, mais je rencontre le même problème !
Code :
$ ./le.x86_64.linux.bin
./le.x86_64.linux.bin: symbol lookup error: ./le.x86_64.linux.bin: undefined symbol: _ZN16CalCoreAnimation11setFilenameERKSs

Mon OS est Ubuntu 15.10
Je suppose que ce blocage est survenu suite à la mise à niveau.
Avez-vous trouvé une solution où sommes nous bloqués ?

Dans le doute et avant de trouver ce fil de conversation, j'avais essayé de réinstaller en suivant la procédure de téléchargement de l'archive tar.gz2, de l'extraire, puis de rendre les .bin exécutables... mais comme j'ai toujours la même erreur, je suis venu vous voir sur le forum :)

Ce qui est dommage c'est que les codes ne sont pas lisibles, je me trompe ?

Edit = pour répondre à
trinita a écrit:
tu aurais la version de GCC ?
bien que je n'ai pas compilé, ma version est la 5.2.1
Donc si je comprends bien, il faudrait que j'installe une version de gcc moins récente, et que je modifie avec un éditeur de texte le makefile.linux pour qu'il prenne en compte cette version précédente ?
Ça me fait un peu peur... et surtout, quelle version conseilles-tu trinita ? je vois dans les sources la 4.7, 4.8, 4.9 et 5...

Re-Edit = bon apparemment, pas possible d'installer une autre version de gcc... ou alors je m'y prends mal.

Auteur:  Sebastien [ 27 Déc 2015, 17:54 ]
Sujet du message:  Re: [Linux] erreur au lancement

J'ai peut-être une idée.

Peux-tu essayer de jongler avec le fichier "./le.x86_64.linux.bin" ?

C'est à dire de prendre le fichier de la compilation et de le faire fonctionner sur le dossier "source non-compilé" ou bien avec le dossier "version complète".

Idée de procédure :
Étape 1) Compilation : "./le.x86_64.linux.bin"
Étape 2) Jongle 1 : Mettre "./le.x86_64.linux.bin" dans un dossier non-compilé et le faire fonctionner
Étape 3) Jongle 2 : Etc.
Étape 4) Déplacement : Déplacer manuellement les fichiers manquant.

NB : Les fichiers manquant seront dans la version complète.

Auteur:  Nehiak [ 22 Mai 2016, 22:46 ]
Sujet du message:  Re: [Linux] erreur au lancement

Salut tout le monde.

Ce problème est il résolu?

J'ai le même problème de mon côté

(pour l'instant pour me connecter ma solution de secours c'est la version windows qui tourne sous wine ..ca fait un peu mal quand même :D )

Auteur:  Finduilas [ 23 Mai 2016, 13:11 ]
Sujet du message:  Re: [Linux] erreur au lancement

J'ai aussi l'erreur avec les binaires dans l'archive fournie, par contre, avec la version compilé, aucun soucis.
Cela viens peut être de la version compilé qui est dans l'archive...

Auteur:  Nehiak [ 23 Mai 2016, 17:04 ]
Sujet du message:  Re: [Linux] erreur au lancement

La compilation du client n'aboutit pas chez moi malheureusement

Auteur:  Finduilas [ 23 Mai 2016, 17:31 ]
Sujet du message:  Re: [Linux] erreur au lancement

Quelle est / sont les erreurs qui sont déclenchés lors de la compilation ?

Auteur:  Nehiak [ 23 Mai 2016, 18:38 ]
Sujet du message:  Re: [Linux] erreur au lancement

Histoire de pas encombrer la page et vu que c'est pas le sujet de base, j'ai mis ca dans un pastebin :)

http://pastebin.com/5QDraeew

Auteur:  Finduilas [ 23 Mai 2016, 19:22 ]
Sujet du message:  Re: [Linux] erreur au lancement

Pour clore la parenthèse.
J'ai eu ces erreurs la aussi. rajoute le mot clef "static" devant la déclaration des fonctions cités, dans le fichier .c. (minimap et weather)
Ça a ensuite compilé et j'ai pas de soucis depuis (j'ai pas beaucoup joué mais ça a tourné plusieurs heures.)
Si tu as un soucis envoie un mp.

Auteur:  Nehiak [ 23 Mai 2016, 20:11 ]
Sujet du message:  Re: [Linux] erreur au lancement

Ça marche ! Nickel et merci à toi!

DOnc pour l'erreur de base, suffit de compiler le client soit même. Je ferais un petit tuto en image à part au cas ou quelqu'un à les mêmes erreurs de compilation que moi!

Auteur:  Nehiak [ 08 Sep 2016, 18:14 ]
Sujet du message:  Re: [Linux] erreur au lancement

J'ai fini par faire ce petit tuto en image par ici:

viewtopic.php?f=104&t=29931

Page 2 sur 2 Le fuseau horaire est UTC+1 heure [Heure d’été]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/