Nous sommes actuellement le 25 Sep 2017, 19:01

Le fuseau horaire est UTC+1 heure [Heure d’été]




Publier un nouveau sujet Répondre au sujet  [ 11 messages ] 
Auteur Message
 Sujet du message: Problème de lancement Ubuntu
MessagePublié: 03 Juin 2017, 02:39 
Hors-ligne

Inscrit(e) le : 03 Juin 2017, 02:32
Message(s) : 6
Bonsoir/Bonjour tout le monde,
Je suis actuellement sur Kubuntu et j'ai installer Landes Eternelles depuis le terminal suivant ce lien : https://doc.ubuntu-fr.org/landes_eternelles
Tout ce passe bien mais au moment de le lancer j'ai la fenere de chargement qui s'affiche puis qui ce ferme et dans mon terminal j'obtient ceci:
./le.x86_64.linux.bin: symbol lookup error: ./le.x86_64.linux.bin: undefined symbol: _ZN16CalCoreAnimation11setFilenameERKSs

J'ai déjà vu une discution sur ce forum dans le m^eme genre mais je n'ai trouvé aucune solution.
Je vous avoue que je sèche un peu :?


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 03 Juin 2017, 21:02 
Hors-ligne

Inscrit(e) le : 14 Mars 2016, 10:52
Message(s) : 90
Localisation : Aix en provence
Salut Mhacks79

Il y a 2 façons d'installer le jeu. Tu installes le jeu et tu le lances ou tu installes les fichiers, tu compiles et tu le lances.
Sous Linux je crois qu'il faut le compiler (de mémoire hein, ça fait un moment maintenant que je l'ai installé.), de base il ne fonctionne pas.

Par contre lors d'une compilation tu auras aussi des erreurs. Ben oui les Landes Éternelles sont cruelles. :lol:

Tu peux corriger les problèmes de compilation assez facilement avec le message de Nehiak qui est très bien fait. Merci à lui.
viewtopic.php?f=104&t=29931

J'espère que tu y arriveras.


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 04 Juin 2017, 01:38 
Hors-ligne

Inscrit(e) le : 03 Juin 2017, 02:32
Message(s) : 6
Salut Saul,

Merci pour ta réponse je vais essayer tout ça je verrais bien ce que ça donne. Je dirais le résultat j'espère que ça va fonctionner :)


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 04 Juin 2017, 03:00 
Hors-ligne

Inscrit(e) le : 03 Juin 2017, 02:32
Message(s) : 6
Je m'en retourne à une autre solution car celle proposée ne m'a pas permis de faire tourner les cruelles landes éternelles comme tu dis :lol: Je ne suis pas certain que ce soit un problème de compilation car le jeu ce lance puis ce ferme avec seulement cette petite erreur mais je pense que cela pourrait venir de ma version d'ubuntu mais je n'en suis pas certain alors si quelqu'un à déjà rencontrer ce problème je suis preneur pour une solution, d'autant que j'ai toujours voulu testé ce jeu :|


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 04 Juin 2017, 15:40 
Hors-ligne
Avatar de l’utilisateur

Inscrit(e) le : 17 Déc 2014, 05:02
Message(s) : 422
Salut à toi.

Quelle versions de KUbuntu utilises tu? Pas sûr d'avoir une réponse à apporter mais je peux faire des tests voir si je trouve quelque choses.

Le post que j'avais fais pour la compilation était sur ma machine actuelle, sous XUbuntu 16.04.1, peut être as tu plus récent?

_________________
Gardien de la Tradition, Forgeron


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 04 Juin 2017, 19:43 
Hors-ligne

Inscrit(e) le : 03 Juin 2017, 02:32
Message(s) : 6
J'ai bien cette version mais quand je fais la commande make -f Makefile.linux
J’obtiens make: *** Aucune règle pour fabriquer la cible « Makefile.linux ». Arrêt.

Du coup je bloque direct forcément :?


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 04 Juin 2017, 23:54 
Hors-ligne
Avatar de l’utilisateur

Inscrit(e) le : 17 Déc 2014, 05:02
Message(s) : 422
Bon bon bon, je sèche un peu j'avoue ... j'ai installé KUbuntu sur une machine virtuelle, j'ai les mêmes soucis d'install que j'avais eu avant mais je n'arrive pas à reproduire ton erreur.

Les 2 petites questions bêtes, mais sait on jamais...

as tu bien installé toutes les dépendances?

Code :
sudo apt-get install libxml2-dev
sudo apt-get install libsdl1.2-dev
sudo apt-get install libopenal-dev
sudo apt-get install libogg-dev
sudo apt-get install libsdl-net1.2-dev
sudo apt-get install libvorbis-dev
sudo apt-get install libsdl-image1.2-dev
sudo apt-get install libcal3d12-dev
sudo apt-get install libxslt1-dev


et quand tu as essayé de lancé le jeu la première fois, tu as utilisé la commande :

Code :
./le.x86_64.linux.bin


As tu aussi tenté

Code :
./le.static.x86_64.linux.bin


?

Sinon j'avoue que je bloque, et que je n'ai pas de réelle solutions à apporter sinon de peut être faire encore un essais avec les sources les plus récentes via le SVN (je n'ai jamais tenté, donc je ne sais pas ce que ca va résoudre )

L'explication pour le SVN est par ici: http://landes-eternelles.com/wiki/participation_au_projet/programmation/subversion

Désolé de ne pouvoir faire mieux, ou alors il faut espérer une réponse d'un plus compétent que moi :)

_________________
Gardien de la Tradition, Forgeron


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 05 Juin 2017, 11:31 
Hors-ligne
Avatar de l’utilisateur

Inscrit(e) le : 17 Déc 2014, 05:02
Message(s) : 422
Bon bon bon, j'ai repris mon p'tit courage à deux main et je me suis replongé dedans.

J'ai toujours pas réussi à obtenir la même erreur, par contre j'ai constaté que l'install en compilant les sources du SVN se passe sans le moindre soucis.

Donc pour reprendre depuis le début une install qui devrait se passer sans soucis:

Code :
cd ~/Desktop/
wget http://www.landes-eternelles.com/client/1900/linux/LandesEternellesLinux-1.9.0.tar.bz2
tar -jxvf LandesEternellesLinux-1.9.0.tar.bz2


Puis les dépendances si elles ne sont pas installées:

Code :
sudo apt-get install libxml2-dev
sudo apt-get install libsdl1.2-dev
sudo apt-get install libopenal-dev
sudo apt-get install libogg-dev
sudo apt-get install libsdl-net1.2-dev
sudo apt-get install libvorbis-dev
sudo apt-get install libsdl-image1.2-dev
sudo apt-get install libcal3d12-dev
sudo apt-get install libxslt1-dev


Ensuite il faut télécharger les sources du client, au lieux de les prendre sur le site, prends celles la et décompresse le fichier sur ton bureau:

https://framadrop.org/r/4vOnzfnAZx#gVUfV0zh5d4oxZZ0MRdFb+cjD9I27jBYou3QYin/ess=


Ce sont les plus à jour, ça t'éviteras de te taper l'installation de subversion


Code :
cd ~/Desktop
cd client_sources
make -f Makefile.linux


Ce coup ci la compilation devrait se passer sans soucis.

Ca va te créer un fichier le.x86.linux.bin qu'il faudra copier/coller dans le répertoire LandesEternellesLinux créer précédemment sur ton bureau, afin de remplacé l'existant.

Code :
cd ~/Desktop/
cd LandesEternellesLinux
./le.x86.linux.bin


Normalement ce coup ci ça devrait marcher ...du moins j’espère. Sinon, je passe définitivement la main à plus doué que moi

_________________
Gardien de la Tradition, Forgeron


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 05 Juin 2017, 13:43 
Hors-ligne

Inscrit(e) le : 03 Juin 2017, 02:32
Message(s) : 6
Merci beaucoup d'avoir pris le temps de m'aider, j'ai effectivement pu lancer la commande make -f Makefile.linux
Mais la compilation ne ce passe malheureusement pas sans souci car j’obtiens encore une bonne tonne d’erreurs pour me dire qu'à la fin la compilation à échouée, du coup je l'ai installé sur Antix avec un autre PC et je n'ai pas eu la moindre erreur avec l'installation toute simple. Du coup peut-être que j'ai mal configuré les pilotes de ma carte graphique, ou bien la GTX950M est vraiment pas pris en charge par le moteur de jeu, je ne sais pas mais je te suis reconnaissant d'avoir pris le temps d'essayer mais je pense que sur ce PC ça va être trop compliqué de l'installer.. :cry:


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 05 Juin 2017, 17:51 
Hors-ligne
Avatar de l’utilisateur

Inscrit(e) le : 17 Déc 2014, 05:02
Message(s) : 422
Pas de quoi, c'est normal :-) Désolé pour toi du coup...on atteint les limites de ce que je peux faire (faut dire qu'elle ne sont pas loin ces limites :P )

Par contre ce qui est sûr c'est que le jeu tourne avec une Nvidia GTX950M ...puisque c'est ce que j'ai (avec le pilote NVIDIA binary driver - version 375.66 depuis nvidia-375)

Si tu as pu l'installé sur un autre pc, bienvenue parmi nous, en espérant que tu prennes du plaisir à jouer.

Pour ce qui est du soucis de base...ça serait pas mal que quelqu'un d'autre passe par là, histoire que tous les problèmes d'installations soient repérés & résolus

_________________
Gardien de la Tradition, Forgeron


Haut
 Profil  
 
 Sujet du message: Re: Problème de lancement Ubuntu
MessagePublié: 05 Juin 2017, 22:22 
Hors-ligne

Inscrit(e) le : 03 Juin 2017, 02:32
Message(s) : 6
Merci :P
Et je suis d'accord car pour ce que j'ai pu trouver sur le forum on est que deux à avoir eu ce problème.


Haut
 Profil  
 
Afficher les messages publiés depuis :  Trier par  
Publier un nouveau sujet Répondre au sujet  [ 11 messages ] 

Le fuseau horaire est UTC+1 heure [Heure d’été]


Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité


Vous ne pouvez pas publier de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum

Recherche de:
Aller vers :  
Powered by phpBB® Forum Software © phpBB Group
Traduit par Maël Soucaze et Elglobo © phpBB.fr